Apache,mod_php,mysql na slackware 10.2???

Sve u vezi mreža i povezivanja na Internet

Moderator: Urednik

Post Reply

offline

Post Napisano: 23 Mar 2006, 15:09


Zdravo!Veoma sam srecan shto konacno postoji sajt za ovu distribuciju sa forumom za resavanje problema.Zelim uspeh celom timu i sto vecu rasprostranjenost ove distribucije!!!
Moj problem je sledeci instalirao sam ver 10.2 i sada mi treba da aktiviram mod php i mysql.Sve shto sam nashao na netu nije pomoglo.Ako neko ko je iskusniji i koji je ovo radio pre mene neka pomogne.Radi se o web serveru jedne lokalne neprofitabilne mreze u zgradi za forum (phpBB2) i josh neke sitnice koje cu drugi put pitati.

Unapred zahvalan Dragan



offline

Post Napisano: 23 Mar 2006, 17:11


Jesi li pogledao zvaničnu dokumentaciju za PHP? Tamo imaš nešto više o podešavanju PHPa pod Apache-ijem. Postoji jedan vrlo često problem u vezi toga... Jedan opcija u Apache-iju. Ne mogu da trenutno da se setim, ali pogledaj.

BTW, ja sam instalirao i Apache i Mysql i PHP, odmah pri instalaciji Slacka i sve piči sasvim OK bez dodatnih podešavanja. Tako da mi je malo nejasno kako je moguće da ti imaš problem sa time.  ???



offline

Post Napisano: 23 Mar 2006, 17:23


mysql sam podesio ali phpmod nikako da proradi!kad odem u httpd.conf nepostoji nijedan LoadModule php.Ajde videcu sta moze da se uradi a ako josh neko zna neka se ukljuci u diskusiju jer svaki komentar je dobrodoshao!!!

10x ;D



offline

Post Napisano: 23 Mar 2006, 18:33


Zdravo evo mene ponovo ali bez uspeha :(!
Evo ovako guglao sam malo i naleteo na neshto da treba da se doda u httpd.conf posto i tako itako ne radi odlucio sam se da rizikujem!
Backapovao sam stari httpd.conf file i onda radio neko dodavanje u njemu.Prvo kako je neki lik rekao je da treba da se doda sledeca linija

Code:
LoadModule php4_module libexec/apache/libphp4.so

to sam dodao gde su i bili svi drugi osim mod-a za php!Sledece sam dodao to je odmah dole sledecu liniju

Code:
AddModule mod_php4.c

i sad na zadnjem mestu je bilo da se doda pri kraju file-a josh

Code:
AddType application/x-httpd-php .php .phtml
AddType application/x-httpd-php-source .phps

Ponovo ne radi!
POMAZITE ljudi poludecu!!!



offline

Post Napisano: 24 Mar 2006, 14:15


[eDo] wrote: Zdravo evo mene ponovo ali bez uspeha :(!
Ostavi default httpd.conf. Zatim ga otvori i idi na sam kraj fajla. Naćićeš sledeću liniju pri kraju:

Code: Select all

#Include /etc/apache/mod_php.conf
Sada, skini tarabu da linija izgleda ovako:

Code: Select all

Include /etc/apache/mod_php.conf
I onda restartuj apača:

Code: Select all

apachectl graceful
Probaj da otvoriš neki .php fajl.



offline

Post Napisano: 28 Mar 2006, 14:34


Upravo to sto je @kotnik rekao uz jednu malu napomenu.
U php_mod.conf fajlu po defaultu namesteno da parsira PHP kod samo kod stranica koje se zavrsavaju sa .php.



offline

Post Napisano: 28 Mar 2006, 21:55


Ja dok sam imao winXP imao sam problema sa mysql , i php  a na linuxu nikakvih eto dokazla po cemu se razlikuje win i linux.. :P



offline

Post Napisano: 29 Mar 2006, 20:33


Nije da skrecem clanove ovog foruma,(sve pohvale, za ekskluzivni srpski Slackware forum),na neki drugi ali nije lose pogledati

http://www.linuxquestions.org/linux/answers/

a za pomenuti problem
http://www.linuxquestions.org/linux/ans ... QL_and_PHP

Da li je neko uspeo da pokrene mySQL Administrator
http://dev.mysql.com/downloads/administrator/1.1.html
inace na FC-u i Suse radi ,ali u Slack-u izginu sa nekim lib-ovima i nista.
Last edited by Dark() on 29 Mar 2006, 20:38, edited 1 time in total.



offline

Post Napisano: 30 Mar 2006, 00:47


Dark() wrote:Da li je neko uspeo da pokrene mySQL Administrator
http://dev.mysql.com/downloads/administrator/1.1.html
inace na FC-u i Suse radi ,ali u Slack-u izginu sa nekim lib-ovima i nista.
Jesi probao sa statičnom verzijom ili sa izvornim kodom?

Koje su biblioteke konkretno u pitanju?



offline

Post Napisano: 30 Mar 2006, 22:35


Probao sam sa izvornim,ali u toku /configure okine, trazi jedan lib, ja da instaliram njega on ima neki dep. ,ja da instaliram taj dep, on ima treci dep. itd. sve do momenta kada na jednom dep.-u nece da proradi /configure neka greska.Ma da crknes.
Staticna nece,cini mi se zbog stare verzije glibc-a ili ??? Ma ne znam vise ni sta sam probao,nego kakva je razlika izmedju:
- Linux (non RPM package) downloads
- Linux x86 generic RPM (statically linked against glibc 2.2.5) downloads


Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests