[rešeno] Problem sa USB tastaturom

Imate problem sa grafičkom karticom, monitorom, periferijama... ovo je mesto za vas

Moderator: Urednik


Administrator
Administrator
offline
User avatar

Posts: 2845
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 08 Jun 2012, 20:46


Evo slike.
Attachments
terminal.png
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Prijatelj foruma
Prijatelj foruma
offline
User avatar

Posts: 699
Joined: 08 May 2007, 12:39
Location: Banja Luka

Post Napisano: 08 Jun 2012, 20:54


Koliko vidim ta tastatura koristi ohci_hcd ("new low speed USB device using ohci_hcd..."), ali tog modula nema u izlazu komande lsmod koji si stavio u prethodnom odgovoru. :-/

Pokušaj sad opet:

Code: Select all

# lsmod | grep -i ohci
Ako ti izbaci taj modul, probaj da odeš u stand-by, pa vidi šta se dešava. Ako ne, učitaj ga ručno sa "modprobe ohci_hcd", pa pokušaj onda da odeš u stand-by.

Edit:

Ponavljam - nevjerovatno mi je da ti niti jedan od ta 3 modula nije učitan, a koristiš USB uređaje. Daj nam još jednom izlaz ove komande i lilo.conf (čisto da eliminišemo mogućnost da je huge kernel i dalje u upotrebi):

Code: Select all

# ls -l /boot/



Administrator
Administrator
offline
User avatar

Posts: 2845
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 08 Jun 2012, 21:05


Probao sam i ručno da ubacim i evo ispisa:

Code: Select all

root@stereo:/# modprobe ohci_hcd
FATAL: Error inserting ehci_hcd (/lib/modules/2.6.37.6/kernel/drivers/usb/host/ehci-hcd.ko): Invalid argument
FATAL: Error inserting ohci_hcd (/lib/modules/2.6.37.6/kernel/drivers/usb/host/ohci-hcd.ko): Device or resource busy
FATAL: Error running install command for ohci_hcd
root@stereo:/# 
A evo i /boot/

Code: Select all

root@stereo:/# ls -l /boot/
total 16188
lrwxrwxrwx  1 root root      37 May 20 20:34 README.initrd -> /usr/doc/mkinitrd-1.4.6/README.initrd
lrwxrwxrwx  1 root root      27 Jun  8 09:50 System.map -> System.map-generic-2.6.37.6
-rw-r--r--  1 root root 1782099 Apr  9  2011 System.map-generic-2.6.37.6
-rw-r--r--  1 root root 2706772 Apr 10  2011 System.map-huge-2.6.37.6
-rw-r--r--  1 root root     512 May 20 20:42 boot.0800
-rw-r--r--  1 root root     512 May 25 00:18 boot.0801
-rw-r--r--  1 root root     353 May 25 00:54 boot_message.txt
lrwxrwxrwx  1 root root      20 May 20 20:41 config -> config-huge-2.6.37.6
-rw-r--r--  1 root root  112324 Apr  9  2011 config-generic-2.6.37.6
-rw-r--r--  1 root root  112298 Apr 10  2011 config-huge-2.6.37.6
-rw-r--r--  1 root root    5040 Mar 27  2011 diag1.img
-rw-r--r--  1 root root   17932 Mar 27  2011 diag2.img
drwxr-xr-x 12 root root    4096 Jun  8 09:51 initrd-tree
-rw-r--r--  1 root root 2930487 Jun  8 09:51 initrd.gz
-rw-------  1 root root   32768 Jun  8 09:53 map
-rw-r--r--  1 root root   15634 Mar 27  2011 slack.bmp
lrwxrwxrwx  1 root root      21 May 20 20:41 vmlinuz -> vmlinuz-huge-2.6.37.6
-rw-r--r--  1 root root 2956592 Apr  9  2011 vmlinuz-generic-2.6.37.6
-rw-r--r--  1 root root 5866144 Apr 10  2011 vmlinuz-huge-2.6.37.6
root@stereo:/# 
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Prijatelj foruma
Prijatelj foruma
offline
User avatar

Posts: 699
Joined: 08 May 2007, 12:39
Location: Banja Luka

Post Napisano: 08 Jun 2012, 21:11


Nešto si pogriješio kod prelaska na generic, jer vmlinuz ti još uvijek pokazuje na huge.

Code: Select all

lrwxrwxrwx  1 root root      21 May 20 20:41 vmlinuz -> vmlinuz-huge-2.6.37.6
Pažljivo isprati sve korake koje sam ti napisao u onom odgovoru i uvjeri se da vmlinuz pokazuje na generic, ne na huge. Obavezno provjeri konfiguraciju Lilo-a (treba da izleda kao što sam napisao) i pokreni "lilo -c" kao root.



Administrator
Administrator
offline
User avatar

Posts: 2845
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 08 Jun 2012, 23:03


Evo ispisa:

Code: Select all

zeljko@stereo:~$ lsmod | grep -i ohci
ohci_hcd               23710  0 
ssb                    46360  1 ohci_hcd
zeljko@stereo:~$ 
Nakon ovoga se ništa ne dešava. Opet je sve po starom.

Nakon još jedne provere prethodnih koraka i ponovo odradio lilo, sporni red sad izgleda ovako:

Code: Select all

lrwxrwxrwx  1 root root      24 Jun  8 22:50 vmlinuz -> vmlinuz-generic-2.6.37.6
Naravno, prvo sam ovo odradio pa onda lsmod komandu i otišao u stand-by.
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 2845
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 16 Aug 2012, 17:21


Nakon prelaska na Slackware 14 RC2 i noviji kernel, opet imam iste probleme. Zapravo problemi nisu nikad ni prestali samo bio manje za računarom pa mi nije smetalo :)
Prilikom učitavanja sistema se lepo vidi da je tastatura prepoznata, zašto posle ne reaguje kad treba da se logujem - nemam pojma.
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 2845
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 17 Nov 2012, 10:33


Evo nakon nekog perioda korišćenja Slackware 14 zvaničnog izdanja, uopšte nemam problema sa tastaturom i stavljam ovu temu pod REŠENO.
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”


Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 1 guest