Orinoco modul ne radi u Slack14?!?

Imate problem sa grafičkom karticom, monitorom, periferijama... ovo je mesto za vas

Moderator: Urednik

Post Reply

offline

Posts: 3
Joined: 14 May 2012, 22:40

Post Napisano: 03 Oct 2012, 20:26


Pozdrav svima ovde na forumu!
Imam wireless karticu sa Prism2.5 cipom i do Slackware-a 13.1 mi je radila sa orinoco modulom
prakticno odmah posle instalacije. Radila je i sa hostap modulom, ali sam onda imao znatno slabiji
signal. Od verzije 13.37 ne mogu da pokrenem karticu sa orinoco modulom iz meni nepoznatog razloga.
Znam da je doslo do promene u nazivu modula iz orinoco_pci u orinoco sa dolaskom novog kernela u 13.37.
Juce sam instalirao Slackware 14 i nisam uspeo da nateram karticu da radi ni sa jednim od pomenutih modula.
Sa hostapom se javlja iwconfig da postoji wlan0, ali ne uspevam rucno da povezem karticu sa AP-om. Takodje
imam i jedan AP koji radi u klijent modu i sa njim sam povezan zicom, ali je interesantno da je internet radio
neko vreme i najednom stao. Nisam imao dovoljno vremena da utvrdim razlog prekida, ali ako je neko imao
slicna iskustva neka javi nesto. Interesuje me da li je doslo do neke izmene u podrsci za ove wireless kartice
i da li je neko uspeo da je natera da radi i kako.



Administrator
Administrator
offline
User avatar

Posts: 2845
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 03 Oct 2012, 21:11


Dobro došao na forum :)
Ja ti ne mogu pomoći sa konkretnom karticom ali uradi pretragu bilo je skoro nekoliko tema u vezi mreža. U svakom slučaju neko će se već javiti sa boljim odgovorom.
Ako ništa drugo ne preostane pitaću za pomoć na #slackware irc kanalu.

Pozdrav!
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 855
Joined: 25 May 2008, 10:44
Location: Valjevo, Srbija

Post Napisano: 03 Oct 2012, 23:10


@nostromo

Dobro došao na forum :). Možeš li da nam daš izlaz sledeće komande:

Code: Select all

# lspci -knn | grep Network -A 5
nije važno samo raditi ono što voliš...važnije je voleti ono što radiš



offline

Posts: 3
Joined: 14 May 2012, 22:40

Post Napisano: 04 Oct 2012, 14:53


@drummer
Evo ovo je izlaz komande:

Code: Select all

bash-4.2# lspci -knn |grep Network -A 5
01:07.0 Network controller [0280]: Intersil Corporation ISL3874 [Prism 2.5]/ISL3872 [Prism 3] [1260:3873] (rev 01)
        Subsystem: Intersil Corporation ISL3874 [Prism 2.5]/ISL3872 [Prism 3] [1260:3873]
02:00.0 VGA compatible controller [0300]: nVidia Corporation G84 [GeForce 8600 GT] [10de:0402] (rev a1)
        Subsystem: Giga-byte Technology Device [1458:3458]
        Kernel driver in use: nouveau
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03) 
A ovo je posle ucitavanja orinoco modula:

Code: Select all

bash-4.2# modprobe orinoco
bash-4.2# lspci -knn |grep Network -A 5
01:07.0 Network controller [0280]: Intersil Corporation ISL3874 [Prism 2.5]/ISL3872 [Prism 3] [1260:3873] (rev 01)
        Subsystem: Intersil Corporation ISL3874 [Prism 2.5]/ISL3872 [Prism 3] [1260:3873]
02:00.0 VGA compatible controller [0300]: nVidia Corporation G84 [GeForce 8600 GT] [10de:0402] (rev a1)
        Subsystem: Giga-byte Technology Device [1458:3458]
        Kernel driver in use: nouveau
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)
bash-4.2# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.
 
Do neke granice mi radi bar zica preko AP koji je prikacen bezicno na adsl. Malo radi malo ne radi. Ranije nisam imao
ovoliko problema sa Slackware-om. Vecinom sam uspevao sam da resim probleme i sve je besprekorno radilo. :(
U medjuvremenu sam skontao i da ne mogu sa kmail-om da iscitam svoje stare mejlove.



Administrator
Administrator
offline
User avatar

Posts: 855
Joined: 25 May 2008, 10:44
Location: Valjevo, Srbija

Post Napisano: 05 Oct 2012, 10:55


Iz ispisa se vidi da orinoco modul nije prihvaćen (da nije učitan za adapter) i zato iwconfig ne prepoznaje wireless adapter. U ovakvim situacijama najčešći uzrok problema je nedostatak adekvatnog firmware-a za adapter. Da bi to proverio, potrebno je da nakon učitavanja orinoco modula u terminalu ukucaš sledeće:

Code: Select all

dmesg | tail
. Ako možeš, u sledećoj poruci nam okači izlaz te komande.
nije važno samo raditi ono što voliš...važnije je voleti ono što radiš



offline

Posts: 3
Joined: 14 May 2012, 22:40

Post Napisano: 06 Oct 2012, 13:39


@drummer

Evo ovo je ispis posle ucitavanja orinoco modula:

Code: Select all

 bash-4.2# modprobe orinoco
bash-4.2# dmesg |tail
[  652.050039] eth0: no IPv6 routers present
[ 1276.289418] cfg80211: Calling CRDA to update world regulatory domain
[ 1276.304350] orinoco 0.15 (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@gnu.org>, et al)
[ 1276.359627] cfg80211: World regulatory domain updated:
[ 1276.359630] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 1276.359633] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1276.359635] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 1276.359636] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 1276.359638] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1276.359640] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)


bash-4.2# lsmod
Module                  Size  Used by
orinoco                58361  0 
cfg80211              145277  1 orinoco
rfkill                 12432  1 cfg80211
snd_seq_dummy           1119  0 
snd_seq_oss            24956  0 
snd_seq_midi_event      4568  1 snd_seq_oss
snd_seq                41599  5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device          4276  3 snd_seq,snd_seq_oss,snd_seq_dummy
snd_pcm_oss            33254  0 
snd_mixer_oss          12984  1 snd_pcm_oss
ipv6                  238549  26 
lp                      7119  0 
fuse                   58282  11 
hid_logitech           13992  0 
joydev                  7668  0 
usbhid                 31118  1 hid_logitech
hid                    65824  2 usbhid,hid_logitech
nouveau               661269  3 
mxm_wmi                 1093  1 nouveau
wmi                     7255  1 mxm_wmi
video                   9938  1 nouveau
ttm                    45384  1 nouveau
drm_kms_helper         22825  1 nouveau
drm                   151850  5 drm_kms_helper,ttm,nouveau
agpgart                22087  2 drm,ttm
processor              23020  0 
thermal                 6587  0 
thermal_sys            12122  3 thermal,processor,video
ppdev                   4710  0 
parport_pc             16755  1 
r8169                  42347  0 
i2c_nforce2             4512  0 
parport                26159  3 parport_pc,ppdev,lp
k10temp                 2131  0 
mii                     3335  1 r8169
snd_hda_codec_realtek   150654  1 
i2c_algo_bit            4543  1 nouveau
i2c_core               16454  5 i2c_algo_bit,i2c_nforce2,drm,drm_kms_helper,nouveau
hwmon                   1033  3 k10temp,thermal_sys,nouveau
snd_hda_intel          19503  2 
snd_hda_codec          70505  2 snd_hda_intel,snd_hda_codec_realtek
snd_hwdep               4802  1 snd_hda_codec
snd_pcm                59013  3 snd_hda_codec,snd_hda_intel,snd_pcm_oss
snd_page_alloc          5925  2 snd_pcm,snd_hda_intel
snd_timer              14798  2 snd_pcm,snd_seq
snd                    43657  15 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_realtek,snd_mixer_oss,snd_pcm_oss,snd_seq_device,snd_seq,snd_seq_oss
soundcore               4570  1 snd
evdev                   7314  5 
button                  3665  1 nouveau
loop                   14650  0 
 

A ovo je posle ucitavanja hostap_pci modula:

Code: Select all

 bash-4.2# modprobe hostap_pci
bash-4.2# dmesg |tail
[ 1471.235589] wifi0: LinkStatus: BSSID=00:60:b3:6e:1c:ac
[ 1471.332395] ADDRCONF(NETDEV_UP): wifi0: link is not ready
[ 1471.332578] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1471.366628] ADDRCONF(NETDEV_UP): wifi0: link is not ready
[ 1471.366789] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1471.377517] wlan0: Preferred AP (SIOCSIWAP) is used only in Managed mode when host_roaming is enabled
[ 1471.388332] wifi0: LinkStatus=2 (Disconnected)
[ 1471.388534] wifi0: LinkStatus: BSSID=44:44:44:44:44:44
[ 1471.422088] wifi0: LinkStatus=2 (Disconnected)
[ 1471.422314] wifi0: LinkStatus: BSSID=44:44:44:44:44:44
 
U medjuvremenu sam uspeo da nateram wifi karticu da radi sa hostapom kao sto se to vidi iz gore postavljenog izlaza
u konzoli, ali tek nakon reinstalacije Slackware-a. Morao sam da se vratim na stari 13.37 da bih arhivirao mejlove iz kmail-a
da bih mogao da ih prebacim u novi sistem. Takodje mi se desilo nesto neobicno, a to je da mi je prestala da radi obicna
mrezna kako u linuxu tako i u windows-u. Nakon gasenja masine i iskljucivanja iz struje ponovo je proradila i to sve mi se
ne svidja jer je ovo nova maticna ploca i ne bih voleo da mi je integrisana mrezna u kvaru jer sam nedavno sve novo
kupio. E sad ima tu jos nesto. Iako je obicna mrezna proradila, ne mogu nikako da uspostavim vezu sa internetom i pored toga
sto je nakacena na adsl preko jednog AP-a u klijent modu.
Znaci sada radi wifi, ali NIC jos ne radi kako treba.


Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest