Nvidia i ATI graficki drajveri!

Imate problem sa grafičkom karticom, monitorom, periferijama... ovo je mesto za vas

Moderator: Urednik

Post Reply

Prijatelj foruma
Prijatelj foruma
offline
User avatar

Posts: 2121
Joined: 08 Jun 2010, 13:28
Location: Centralna Srbija Kraljevo
Contact:

Post Napisano: 05 Aug 2013, 11:05


A što bi to radio? Ako ti sve radi kako treba, ništa ja tu ne bih dirao, jel "zezanje" sa Xorg serverom može da izazove svašta.
Isto kao i ti, imam vlasničke nVidia drajvere, i ne pipam ništa oko Xorga. :)

Ovo što ja navodim za nVidu optimus je sasvim druga priča. Taj drajver koja je nVidia napisala je samo za nVidia Optimus tehnologiju (čuveni LInusov prst upućen nVidii :)) i da bi taj drajver radio kako valja treba mu što svežiji Xorg server.
Registrovani Linux korisnik #487729
Upostovano sa Linuks Operativnog Sistema



Administrator
Administrator
offline
User avatar

Posts: 4108
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 15 Oct 2013, 10:09


Kakvo je stanje sa propriatry ATI drajverima i kernelom 3.10? Približava se 14.1 pa bi bilo korisno znati. Znam da neki od vas već guraju Current, pa možda imate neku dodatnu informaciju.



Administrator
Administrator
offline
User avatar

Posts: 2826
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 15 Oct 2013, 11:02


Radi beta drajver 13.8. Igram igrice i sve radi kao što se i očekuje.

Послато са куцаће машине користећи Тапаток 2 :)
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Prijatelj foruma
Prijatelj foruma
offline
User avatar

Posts: 2121
Joined: 08 Jun 2010, 13:28
Location: Centralna Srbija Kraljevo
Contact:

Post Napisano: 15 Oct 2013, 12:04


Može isto pitanje ali sa nVidia drajverom. :)
Registrovani Linux korisnik #487729
Upostovano sa Linuks Operativnog Sistema



Administrator
Administrator
offline
User avatar

Posts: 2826
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 26 Oct 2013, 12:49


Situacija na 14.1 je malo izmenjena što se tiše AMD drajvera. Nakon nekih nadogradnji, sumnjam na mesa iz jedne od poslednjih nadogradnji, 13.8 beta više ne radi kako treba. Možda i nije mesa nadogradnja napravila problem ali nešto jeste. Problem se javio prilikom pokretanja dve igrice i google-earth. Google earth je prijavljivao na nemam odgovarajuću grafičku karticu. Supertuxkart nije hteo da se makne od početnog ljubičastog ekrana. Brutal legend, koji igram preko steam-a, prijavljivao je problema neki shader čudima tralala.

Instalacija amd 13.11 beta v1 drajvera je uklonila probleme i sad sistem opet radi kako treba.

Čisto da budete informisani :)

P.S. za Nvidia stvarno nemam kako i gde da testiram, sorry
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 2826
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 20 Jan 2014, 14:01


13.12 AMD grafički drajveri za Linux su izašli ali iz nekog razloga se ne instaliraju kako treba. 13.11 beta i dalje rade dobro svoj posao.
Nemam vremena da analiziram problem pa ako neko stigne slobodno neka javi bilo šta korisno :)
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 4108
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 16 Jul 2014, 08:26


Mount & Blade nije jedina igra koja ne radi sa 14.6 beta.

Takođe su problematične i:
  • Anomaly - War on Earth
  • Antichamber
  • Breach and Clear
  • Mark of the Ninja
Sve ove igre rade sa poslednjom Mesom (10.2.3).

Igre koje rade sporije nego sa poslednjom Mesom:
  • Montague's mount
  • Realms of Arcania: Blade of Destiny
Mesa u verziji 10.2 prilično kompletno implementira OpenGL 3.x tako da neke nekad problematične igre danas rade ok. Ono gde Mesa škripi je OpenGl 4.x podrška (nekompletna je). Ono gde je fglrx najbagovitiji je GLSL - najveći broj problema sa igrama je u vezi sa bagovima u AMD-ovoj GLSL 3.x/4.x implementaciji.

Mali dodatak: Ovo je sjajan pregled stanja Mesa drajvera i implementacije OpenGL 4: http://www.phoronix.com/scan.php?page=n ... px=MTcwMDc" onclick="window.open(this.href);return false; i http://www.phoronix.com/scan.php?page=n ... px=MTcwMTE" onclick="window.open(this.href);return false;. U git verziji bi moglo biti izmena po tom pitanju. Ovo važi za Mesu 10.2.x.

Još jedna dopuna: Trenutno stanje implementacija OpenGL 3.x i 4.x iz Mesinog GIT repozitorija: http://cgit.freedesktop.org/mesa/mesa/tree/docs/GL3.txt" onclick="window.open(this.href);return false;.



Administrator
Administrator
offline
User avatar

Posts: 4108
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 16 Jul 2014, 09:39


bocke wrote:Igre koje rade sa fglrx, ali ne rade sa poslednjom Mesom:
  • X-Com: Enemy Unkown
Izvinjavam se na dezinformaciji. Problem je launcher. Kada se igra ručno pokrene radi. I to čak bolje nego na fglrx. Brišem iz liste. :)



Administrator
Administrator
offline
User avatar

Posts: 4108
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 05 Jun 2015, 15:39


Stigao Catalyst 15.5 :)
http://support.amd.com/en-us/download/d ... =Linux+x86" onclick="window.open(this.href);return false;

Nisam još stigao da probam. Moram da proverim da li imam backup Mesa drajvera pre igranja sa njime.



Poznata ličnost
Poznata ličnost
offline
User avatar

Posts: 148
Joined: 17 Jul 2015, 17:09

Post Napisano: 19 Sep 2015, 13:49


Aloha svima!

Nadam se da je pravo mesto za pitanje u vezi Mesa drajvera.
Potrebna mi je neka novija verzija od postojeće.

Code: Select all

glxinfo | grep -i version
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL version string: 2.1 Mesa 9.1.7
OpenGL shading language version string: 1.30
Koji način je bajbezbedniji za nadogradnju/reinstalaciju?
Ne mora poslednja verzija, ako nije stabilna. Dovoljno je da podržava OpenGL 3.1.
Osim ako smatrate da je vlasnički drajver bolje rešenje?

Što se vlasničkih drajvera tiče, nisam siguran s kojim kernelom pokušati (vidi dole),
jer sam pročitao da poslednja Mesa i kernel 4.16 mogu spržiti X-server, a za Catalyst drajvere
piše "up to 3.19 kernel".

Detalji o sistemu:
- Slackware64 (multilib); trenutno kernel 4.16 (funkcionalan je i 3.18.21)
- grafika ATI Radeon HD6450 Caisos
(Family=Northern Islands = OpenGL 4.x; shader model 5; DX 11; Max.texture/Renderbuffer size 16384)

Hvala! :beer:
Last edited by dr_mr_foo on 19 Sep 2015, 14:27, edited 1 time in total.


Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest