Sta sa kernel-headers paketima posle nadogradnje

Potrebna vam je pomoć pri instalaciji? U ovom forumu možete postavljati pitanja.

Moderator: Urednik

Post Reply

offline

Posts: 3
Joined: 26 May 2016, 20:58

Post Napisano: 03 Jun 2016, 16:01


Zdravo svima :)

Nedavno sam presao sa Debiana na Slack, pa nisam siguran šta se radi u ovakvim situacijama, tamo to sve završi apt-get. Dakle, skinuo sam i instalirao current64, sve lepo radilo, nema problema. Bio sam dobar učenik i uradio sav RTFM, il' barem mislim da jesam. Uradio sam update i upgrade sa slackpkg, instalirao šta mi je trebalo sa SBo. Stigoše i novi kerneli u current, pa rekoh, vreme je i to da se nadogradi, trebalo bi da je to poslednji update pre nego sto current postane zvanican 14.2. Uradio sam kao sto se preporučuje, zadržao stare kernele, odradio sta trebe u /etc/lilo.conf da imam boot i sa novim i sa starim kernelom, uradio lilo -v, reboot, sve radi kako treba, E, sad, ja sam skinuo i instalirao sve kernel pakete, računajući i kernel-headers pakete. Da li je njih potrebno nadogaditi sa upgradepkg, il' nema veze ako su instalirani i 4.4.10 i 4.4.12?



Administrator
Administrator
offline
User avatar

Posts: 4337
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 03 Jun 2016, 19:05


Pozdrav.

Ako si radio upgrade putem slackpkg ili upgradepkg, onda je kernel-headers već ažuriran na najnoviju verziju. Osim ako nisi instalirao novi krenel sa installpkg, umesto upgradepkg. Ako si tako radio, sistem će koristiti kernel-headers one verzije na koju pokazuje simbolički link /usr/src/linux.

Inače, nema potrebe da se dve verzije kernela između kojih nema većih razlika (kao napr 4.4.10 i 4.4.12) instaliraju jedna pored druge osim ako jedna od njih nije kompajlirana ručno.



Administrator
Administrator
offline
User avatar

Posts: 4337
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 03 Jun 2016, 19:33


Btw, kernel-headers nije preporučljivo ručno nadograđivati (iz neproverenih paketa ili pomoću make headers-install), već isključivo samo iz paketa iz zvaničnih repoa. Razlog za ovo je što taj paket treba da odgovara verziji kernela sa kojim je kompajlirana sistemska C biblioteka (glibc), nebitno od aktuelno pokrenutog kernela.

Uopšteno, ako koristiš zvanične repoe i preporuke iz dokumentacije koja dolazi uz Slack, to nije problem. Ako instaliraš prilagođene verzije kernela nemoj da koristiš make headers-install ili da ručno kopiraš headere u /usr/include.

U svakom slučaju, dobro overi docs.slackware.com članak o upgradeu za potencijalne dodatne informacije o upgradeu pomoću slackpkg.



offline

Posts: 3
Joined: 26 May 2016, 20:58

Post Napisano: 03 Jun 2016, 19:42


Nije azuriran, skinuo sam ga "rucno" i uradio installpkg. Koliko sam video na vise mesta i u dokumentaciji, automatski upgrade kernela koji radi se ne preporucuje, kao ni brisanje istog dok nisi siguran da je sve u redu sa novim. Tako da za kernele nisam koristio slackpkg ni upgradepkg, sve ostalo je uradjeno sa slackpkg, plus malo rucnog sa SBo i VLC paket od aliena. A posto jos nisam u Slack-u "kao kod kuce", gledam da radim na siguricu, pa zadrzavam oba kernela, dok ne postane zvanicno 14.2.
Ako si tako radio, sistem će koristiti kernel-headers one verzije na koju pokazuje simbolički link /usr/src/linux.
Hmm, cisto da budem siguran:

Code: Select all

#readlink -f kernel.headers*
/usr/src/linux-4.4.12/kernel/kernel.headers*
Znaci da koristi 4.4.12 kernel-headers? Sto je i logicno, jer sam se ulogova sa 4.4.12. Pretpostavljam da bi koristio 4.4.10 ako se ulogujem sa tim kernelom. U svakom slucaju, hvala za pomoc i brz odgovor :)



Administrator
Administrator
offline
User avatar

Posts: 4337
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 03 Jun 2016, 19:59


dejank wrote:Nije azuriran, skinuo sam ga "rucno" i uradio installpkg. Koliko sam video na vise mesta i u dokumentaciji, automatski upgrade kernela koji radi se ne preporucuje, kao ni brisanje istog dok nisi siguran da je sve u redu sa novim. Tako da za kernele nisam koristio slackpkg ni upgradepkg, sve ostalo je uradjeno sa slackpkg
To se odnosi na ručno kompajliranje kernela. :) Nema potrebe da to radiš čak ni za current, a kamoli stable (trenutni current je pre-release - to u Slackware terminologiji znači da je gotovo pa stable). Kada ručno instaliraš iz izvornog koda to sve stoji. Ali kada koristiš slackpkg, ne postoji potreba da se opterećuješ s time. Patrick (autor Slackwarea) i Slackware tim se brinu o tome za tebe (verzije kernel-hedaera, itd).



offline

Posts: 3
Joined: 26 May 2016, 20:58

Post Napisano: 03 Jun 2016, 20:31


Ma, verujem ja i Patricku i ostatku tima, al' sam se vodio ovim sa http://docs.slackware.com/howtos:slackw ... temupgrade" onclick="window.open(this.href);return false;:
Considerations about the Kernel

Just running slackpkg and hoping for the best is not going to work. Some considerations have to be cared for. One important thing to remember:

Never upgrade your working kernel.

Why is that? Simple - you will be upgrading potentially hundreds of packages and should be prepared for the unlikely event that your computer does not work properly anymore after a system upgrade. One thing you don't want to get hit by is a system which does not boot at all. A new Slackware release may install a kernel that refuses to boot your computer (small chance but nevertheless… be prepared). For that reason, you need to keep your “old” working kernel installed, and keep a section for it in your /etc/lilo.conf file. That way, if the new kernel fails to boot, you can fall-back to the old kernel and start investigating what went wrong.
Basically, these are the same precautions you must take when you are compiling a new kernel yourself.
Tamo jos preporucuju da se obavezno kernel paketi stave u blacklist za slackpkg. I tako na jos par mesta, npr http://www.linuxquestions.org/" onclick="window.open(this.href);return false; u vise postova na forumima. Ili to vazi samo za nadogradnju sa jedne verzije na drugu, npr 14.0 na 14.1, ali ne i za nadogradnju kernela na istoj verziji?



Administrator
Administrator
offline
User avatar

Posts: 4337
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 03 Jun 2016, 20:47


Da, ok. Ali to se odnosi na upgrade sa jedne stabilne verzije (napr 14.1) na drugu (napr 14.2). Ne na update jedne iste verzije. Recimo, ako furaš current, prethodna verzija bi bila 14.1. 14.1 ne uključuje kernel 4.x, već 3.8.x (ako se dobro sećam).

Tj. update nije isto što i upgrade. :)

Iako to jeste napisano malo oprezno kako bi se izbegli potencijalni problemi.


Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests