SLiM login manager problem

Teme koje se tiču podešavanja i zanimljivosti u vezi desktop okruženja

Moderators: Sinisa, Urednik

Post Reply

Povremen korisnik
Povremen korisnik
offline
User avatar

Posts: 29
Joined: 01 Feb 2018, 11:37

Post Napisano: 23 May 2019, 13:06


Nisam siguran da li sam otvorio temu na pravom mestu, pa se unapred izvinjavam ako sam pogrešio.

Siguran sam da neko sa foruma zna rešenje, iskreno nisam uspeo da ga pronađem.
Neko kratko vreme je Slim radio kako treba, logovao sam se, iznenada više ne može.

Na slici je problem koji prijajvljuje sa /var/run/slim.auth fajlom. Ono što sam jednom uradio, jer nisam znao šta drugo probati, stavio sam vlasništvo nad tim fajlom da bude za usera, umesto za root. Posle restarta je proradilo, ali nakon drugog restarta nije, jer je taj fajl izgleda privremen i stalno se briše i ponovo kreira kao root.

Kontam da je potrebno u toku pokretanja slim-a da se taj fajl kreira kao user i omogući startovanje slim-a.
U prilogu je tekstualni fajl slim.conf, slika i tekstualni fajl mog .xinitrc-a(nisam znao kako se postavlja tekst unutar spoiler-a).
Inače, nigde nisam mogao da nađem kako se automatski startuje login, već samo to, da se iz init3 prebaci u 4, ali to nije dovoljno na Slack-u.

Inace, u /etc/inittab je default session:4. Iz terminala kao user mi normalno radi startx, i default session je Openbox.
Ispoštovao sam sve sa linka: https://docs.slackware.com/howtos:window_managers:slim
Attachments
xinitrc.txt
(944 Bytes) Downloaded 12 times
slim.conf.txt
(3.1 KiB) Downloaded 12 times
slim error.PNG



Povremen korisnik
Povremen korisnik
offline
User avatar

Posts: 29
Joined: 01 Feb 2018, 11:37

Post Napisano: 25 May 2019, 14:07


Rešio sam sam na kraju problem na neverovatno jednostavan način... Ništa od onog što sam iskopao na netu nije pomoglo.
Rešenja koja iskaču su vezana za Arch, Fedora, Debian, za Slackware ne postoji ništa sem wiki stranice za podešavanje SLiM-a, što može da znači da niko nikad nije imao ovakav problem... U šta ne verujem :cool:

Za navedene distribucije kao rešenje, bilo je raznih varijanti, neke logične su ponovno generisanje .Xauthority fajla u okviru /home/user direktorijuma, zatim brisanje .xinitrc fajla koji se generiše komandom xwmconfig, ali to mi nije pomoglo. (touch ~/.Xauthority, plus par komandi za kreiranje varijabli unutar tog fajla), očigledno mi je to odmoglo, jer je u Slackware-u dovoljno samo rm ~/.Xauthority), jer sam imao grešku autentifikacije za /var/run/slim.auth.

Moje rešenje je brisanje .Xathority fajla, samo tog jednog fajla, reboot, zatim to nije bilo dovoljno, već sam iz nekog razloga morao da reboot-ujem još jednom VM, ili ugasim/upalim, zatim se pojavljuje slim Login sa slike. Prvi put sam obrisao 3 fajla iz home (.Xauthority, .xinitrc, .xsession). Fajl .xinitrc je potreban za login, bez njega nećete moći da se ulogujete sa svojim user-om. .Xauthority se sam generiše, za .xsession nisam siguran, njega sam vratio iz backup-a, kao i .xinitrc, mada se on valjda generiše xwmconfig komandom.

E da, bitno je da naglasim da sam imao problem nakon promene teme slim login prozora u /etc/slim.conf, posle toga sam dobio problem sa .auth, koji je rešen brisanjem .Xauthority fajla, pa reboot 2 puta. Ne znači da će uvek biti problem, ja računam da je možda to kod mene jer je u pitanju virtuelna mašina.

Možda malo zbunjujuće, ali i jeste, jer nekako baš i nema logike da se ove sitnice dešavaju, ali eto ja znam sada kako to da rešim, pa ako još neko bude imao problem, rado ću pomoći.

PS nešto se čudno dešava sa mojom VM, izgleda da svaki drugi put kada se restartuje ili ugasi, nakon podizanja ima problem sa prikazivanjem SLiM login prozora, pa nakon restarta se pojavi, nemam pojma zbog čega, ali možda je do mog sistema, jer ima neki problem i sa update-ovanjem. Moguće je da sam nešto poremetio kada sam instalirao silne biblioteke za Cantata-u, moraću to sve da počistim. Druga mašina kod kuće na Workstation-u sa svežim Slackware 14.2 x64 update-uje se bez problema i odlično radi openbox i SLiM, ali ona je čista.

Sve u svemu, SLiM je veoma dobar LM, baš fino leži sa ovom slackware-black temom. Ima naravno i drugih tema, kao npr ova za KDE4, izgleda apsolutno fenomenalno: https://www.opendesktop.org/p/998002/
Attachments
slim-black.PNG
slim-black.PNG (9.73 KiB) Viewed 235 times



Povremen korisnik
Povremen korisnik
offline
User avatar

Posts: 29
Joined: 01 Feb 2018, 11:37

Post Napisano: 29 May 2019, 21:30


Izgleda da ipak nije do kraja rešen problem, ali možda znam kako to rešiti. Trebalo mi je malo vremena dok sam video kada se javlja problem, ipak nije slučajnost.

Ono što me malo nervira je, i dalje se dešava na sveže instaliranom sistemu, sve lepo radi kada se instalira SLiM, on se lepo podiže, sve lepo radi, do trenutka kada hoću recimo da mi se podigne vncserver preko koga hoću da pristupam. Definisao sam da se startuje kao user prilikom podizanja sistema, koristeći skriptu rc.local. Varijabla je: sudo -u user vncserver -geometry 1440x900 -depth 24 :0

Problem je što se on ne startuje nakon svakog reboot-a, i posle toga se ni SLiM ne startuje pri svakom podizanju sistema, već svaki drugi ili treći put.
Onda kada se ne startuje, piše "bad magic cookie", ili da nedostaje slim.auth. Kada opalim reboot, onda se startuje normalno, ali onda recimo nema vncservera... A nekad se oba startuju. Očigledno je da nije dobro rešenje postavka u rc.local za vnc, šta je po vama pametnije?
Da li staviti vncserver sa nekim delay-om, tj., da vncserver sačeka nekoliko sekundi nakon podizanja mašine, i kako je najbolje to uraditi? Preko sh skripte i staviti u crontab, možda? Ili možda komanda uz neki delay, pa ubaciti u rc.local?


Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests